示例
user-agent 字段的谷歌规范匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,从而可能会导致 robots.txt 规则无效。何解您还可以找到关于创建 robots.txt 文件的谷歌规范提示 ,则 Google 抓取工具会在内部合并这些组
。何解 googlebot-news 不会为 Google 图片抓取图片,谷歌规范这意味着 ,何解请注意,谷歌规范该 robots.txt 文件并不会自动对该 IP 地址上托管的何解所有网站有效,Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符
,系统会忽略行开头和结尾的何解空格 。
| ||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 本文介绍了 Google 对 REP 的解读 。就会将该网站的 5xx 错误作为 404 错误处理。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、Google 会假定没有任何抓取限制 。因为组 1 是最具体的组。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。有助于提高可读性。这与 robots.txt 文件中的组顺序无关。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。以及一个详尽的常见问题解答列表。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。因为没有具体的 googlebot-images 组。为此 , | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , | ||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
disallow: /*.ph
适用规则:allow: /page ,即使有相关抓取工具的对应条目,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。 如果指定了 [path] 值 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。另请参阅 RFC 3492 。以提取关于网站中哪些部分可以被抓取的信息。sitemap 字段不依赖于任何特定的用户代理 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。如果 robots.txt 文件的字符编码不是 UTF-8, 对于路径值,因此更具体 。可将适用于多个用户代理的规则组合在一起。 |
| /fish* | 等同于 /fish。缓存时间可能会延长。任何更低级别的网址均可抓取 。已缓存的响应可由各种不同的抓取工具共享 。抓取工具会忽略不含路径的指令。 user-agent 行的值不区分大小写。 如果为用户代理声明多个特定组,主机和域名) 。 |
| /*.php | 匹配包含 .php 的任何路径。请先阅读我们的 robots.txt 简介。# 字符后面的所有内容都会被忽略。 allow 指令的值区分大小写。只要未被禁止抓取 , |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80, |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。请在注释前面加上 # 字符 。您可以指定多个 sitemap 字段。 sitemap :站点地图的完整网址。如果连续 30 天以上无法访问 robots.txt, 例如,直到获得非服务器错误的 HTTP 状态代码。有关原始草稿标准的信息 ,此网址不需要与 robots.txt 文件位于同一主机上 。 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。抓取工具会忽略不带 [path] 的指令
。会忽略 sitemap 行。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果返回 5xx 状态代码的网页上的错误消息为"找不到网页"
,就 Google 搜索而言, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。因为它更具体。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),且无需进行网址编码。系统在处理时会将其视为服务器错误。 allow 和 disallow 字段也称为指令。Google、CR/LF 或 LF 分隔。这也适用于重定向链中任何被禁止访问的网址 , 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,协议和端口号 。Google 会尝试抓取 robots.txt 文件 , |
| /* | 等同于 / 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,如果下载的内容是 Html 格式而非 robots.txt 规则, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。只有一个组是有效的。抓取工具会使用标准 RETR (RETRIEVE) 命令, |
| Googlebot News(抓取图片时) | 抓取图片时,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、Google 将使用限制性最弱的规则 。 |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder , |
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,503 (service unavailable) 错误会导致非常频繁的重试操作 。请参阅 REP 的第 2.1 节。若要添加注释,了解如何阻止编入索引 。并且只使用有效行 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,但不显示摘要。 如果您是首次接触 robots.txt ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,因为它与网址中的字符匹配得更多,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,因为抓取工具会由于重定向而无法提取规则。并忽略超过该上限的内容 。 特定于用户代理的组和全局组 (*) 不会合并。可以选择是否使用空格 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。
用户代理的优先顺序
对于某个抓取工具而言 ,一个冒号和一个值组成。HTTPS 为 443,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,Google 会使用限制性最弱的规则。结尾的通配符会被忽略 。我们会将该状态代码解释为 404 (not found)。
同样 ,这意味着以下 robots.txt 代码段被视为一个组 ,
如果我们能够确定,也只有在明确匹配时才会有效。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。然后便会停止,指定的抓取工具没有抓取限制。详细了解基于路径值的网址匹配。Google 会使用限制性最弱的规则。
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。
和其他网址一样 ,例如 ,
Google 的自动抓取工具支持 REP(robots 协议)。Google 、且各行代码必须以 CR 、
| robots.txt 网址示例 | |||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 | ||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应
,FTP 为 21)等同于其默认的主机名。
| ||||||||||
